by

Inilah User Profiles Voucher WiFi Mikrotik Mikhmon di Salira Coffee & Pool

TASIKMALAYA, LANGSUNG VIRAL DOT COM – Ini hanya backup pemahaman saya saja om. Artikel ini nyambung dengan suatu video di channel youtube dengan judul “Melihat Daftar User Profiles Voucher WiFi Mikrotik Mikhmon Punya-nya Salira Coffee & Pool

Dan artikel ini bertindak sebagai penyimpan teks kode nya, sebagaimana dijelaskan di video tersebut. OK.

Masuk ke menu : IP – Hotspot – klik tab User Profiles.

Ini om kode-kode nya :

PAKET-HOTSPOT-1-JAM, untuk pengunjung yang jajan di Salira Coffee & Pool yang nominalnya di bawah Rp. 5.0000,- (Rp. 1 s.d Rp. 4.999,-) dalam satu kali transaksi). Tidak berlaku kelipatannya.

:put (",,0,,,noexp,Enable,"); [:local mac $"mac-address"; /ip hotspot user set mac-address=$mac [find where name=$user]]
local a $user;
local b $"mac-address";
if ([len [/system scheduler find name="offinet-PAKET-HOTSPOT-1-JAM-$a"]] = 0) do={[
/system scheduler add interval=1h name="offinet-PAKET-HOTSPOT-1-JAM-$a" on "/ip hotspot user remove [find name=$a];
/ip hotspot host remove [find mac-address=$b];
/ip hotspot active remove [find mac-address=$b];
/ip hotspot cookie remove [find mac-address=$b];
/system scheduler remove [find name=offinet-PAKET-HOTSPOT-1-JAM-$a]"]}

PAKET-HOTSPOT-1-HARI, Untuk pengunjung yang Jajan di Salira Coffee & Pool, lebih dari Rp. 5.000, (sekali transaksi)

Settingan untuk PAKET-HOTSPOT-1-HARI adalah sebagai berikut :

:put (",,0,,,noexp,Enable,"); [:local mac $"mac-address"; /ip hotspot user set mac-address=$mac [find where name=$user]]
local a $user;
local b $"mac-address";
if ([len [/system scheduler find name="offinet-PAKET-HOTSPOT-1-HARI-$a"]] = 0) do={[
/system scheduler add interval=1d name="offinet-PAKET-HOTSPOT-1-HARI-$a" on "/ip hotspot user remove [find name=$a];
/ip hotspot host remove [find mac-address=$b];
/ip hotspot active remove [find mac-address=$b];
/ip hotspot cookie remove [find mac-address=$b];
/system scheduler remove [find name=offinet-PAKET-HOTSPOT-1-HARI-$a]"]}

PAKET-HOTSPOT-7-HARI, untuk paket spesial, orang-orang tertentu saja.

:put (",,0,,,noexp,Enable,"); [:local mac $"mac-address"; /ip hotspot user set mac-address=$mac [find where name=$user]]
local a $user;
local b $"mac-address";
if ([len [/system scheduler find name="offinet-PAKET-HOTSPOT-7-HARI-$a"]] = 0) do={[
/system scheduler add interval=7d name="offinet-PAKET-HOTSPOT-7-HARI-$a" on "/ip hotspot user remove [find name=$a];
/ip hotspot host remove [find mac-address=$b];
/ip hotspot active remove [find mac-address=$b];
/ip hotspot cookie remove [find mac-address=$b];
/system scheduler remove [find name=offinet-PAKET-HOTSPOT-7-HARI-$a]"]}

PAKET-HOTSPOT-14-HARI, nah ini juga untuk paket spesial sih, hanya orang-orang tertentu saja.

:put (",,0,,,noexp,Enable,"); [:local mac $"mac-address"; /ip hotspot user set mac-address=$mac [find where name=$user]]
local a $user;
local b $"mac-address";
if ([len [/system scheduler find name="offinet-PAKET-HOTSPOT-14-HARI-$a"]] = 0) do={[
/system scheduler add interval=14d name="offinet-PAKET-HOTSPOT-14-HARI-$a" on "/ip hotspot user remove [find name=$a];
/ip hotspot host remove [find mac-address=$b];
/ip hotspot active remove [find mac-address=$b];
/ip hotspot cookie remove [find mac-address=$b];
/system scheduler remove [find name=offinet-PAKET-HOTSPOT-14-HARI-$a]"]}

PAKET-HOTSPOT-30-HARI, ini juga paket spesial, hanya berlaku untuk orang-orang tertentu saja.

:put (",,0,,,noexp,Enable,"); [:local mac $"mac-address"; /ip hotspot user set mac-address=$mac [find where name=$user]]
local a $user;
local b $"mac-address";
if ([len [/system scheduler find name="offinet-PAKET-HOTSPOT-30-HARI-$a"]] = 0) do={[
/system scheduler add interval=30d name="offinet-PAKET-HOTSPOT-30-HARI-$a" on "/ip hotspot user remove [find name=$a];
/ip hotspot host remove [find mac-address=$b];
/ip hotspot active remove [find mac-address=$b];
/ip hotspot cookie remove [find mac-address=$b];
/system scheduler remove [find name=offinet-PAKET-HOTSPOT-30-HARI-$a]"]}

PAKET-HOTSPOT-RUMAHAN, ini juga spesial untuk orang-orang tertentu di rumah.

password 472258124 adalah hanya contoh saja.

:put (",,0,,,noexp,Enable,No,Simple,,,,,,,");[:local mac $"mac-address"; /ip hotspot user set mac-address=$mac [find where name=$user]]
local a $user;
local b $"mac-address";
if ([/ip hotspot user get [find name="$a"] comment] = "") do={[
/ip hotspot user remove [find name=$b];
/ip hotspot user set [find name=$a] comment=$a mac-address=$b name=$b password="472258124";
/system scheduler add name=$b interval="00:00:02" on "/ip hotspot active remove [find mac-address=$b];
/ip hotspot host remove [find mac-address=$b];
/ip hotspot cookie remove [find mac-address=$b];
/system scheduler remove [find name=$b]"]}

PAKET-HOTSPOT-SALIRA-COFFEE-AND-POOL. Spesial untuk Sistem Salira Coffe & Pool kelak kedepannya, inginnya pakai profile ini, tapi masih di pertimbangkan bagaimana-bagaimananya.

:put (",,0,,,noexp,Enable,"); [:local mac $"mac-address"; /ip hotspot user set mac-address=$mac [find where name=$user]]
local a $user;
local b $"mac-address";
if ([len [/system scheduler find name="offinet-PAKET-HOTSPOT-SALIRA-COFFEE-AND-POOL-$a"]] = 0) do={[
/system scheduler add interval=2h name="offinet-PAKET-HOTSPOT-SALIRA-COFFEE-AND-POOL-$a" on "/ip hotspot user remove [find name=$a];
/ip hotspot host remove [find mac-address=$b];
/ip hotspot active remove [find mac-address=$b];
/ip hotspot cookie remove [find mac-address=$b];
/system scheduler remove [find name=offinet-PAKET-HOTSPOT-SALIRA-COFFEE-AND-POOL-$a]"]}

PAKET-HOTSPOT-TEAM, ini adalah khusus untuk Tim Salira Coffee & Pool

password 472258124 adalah hanya contoh saja.

 

:put (",,0,,,noexp,Enable,No,Simple,,,,,,,");[:local mac $"mac-address"; /ip hotspot user set mac-address=$mac [find where name=$user]]
local a $user;
local b $"mac-address";
if ([/ip hotspot user get [find name="$a"] comment] = "") do={[
/ip hotspot user remove [find name=$b];
/ip hotspot user set [find name=$a] comment=$a mac-address=$b name=$b password="472258124";
/system scheduler add name=$b interval="00:00:02" on "/ip hotspot active remove [find mac-address=$b];
/ip hotspot host remove [find mac-address=$b];
/ip hotspot cookie remove [find mac-address=$b];
/system scheduler remove [find name=$b]"]}

Semoga bermanfaat ya.
Salam sukses buat usaha WiFi nya.

Comment

Leave a Reply

Your email address will not be published. Required fields are marked *

Artikel terkait lainnya