by

Catatan Penting Settingan Voucher WiFi Warkop Salira per 25 Mei 2020

Langsung Viral dot com – Saya ikut settingan 2 isp om ega.

Oke om, kita akan kelompokkan ke sebagai berikut saja ya om :

Setup Nama Interface

Setup IP Address

Setup NAT

Setup Mangle

Setup IP Route

Setup IP Pool

Setup DNS

Setup DHCP

Setup Hotspot (Server, Server Profile, User Profile, IP Binding)

Setup Server

Setup Server Profile

Setup Server Profile – General

Setup Server Profile – Login

Setup Hotspot – User Profiles

Setup Hotspot – User Profiles – PAKET-HOTSPOT-1-HARI – General

Setup Hotspot – User Profiles – PAKET-HOTSPOT-1-HARI – Queue

Setup Hotspot – User Profiles – PAKET-HOTSPOT-1-HARI – Script

:put (",,0,,,noexp,Enable,"); [:local mac $"mac-address"; /ip hotspot user set mac-address=$mac [find where name=$user]]
local a $user;
local b $"mac-address";
if ([len [/system scheduler find name="offinet-PAKET-HOTSPOT-1-HARI-$a"]] = 0) do={[
/system scheduler add interval=1d name="offinet-PAKET-HOTSPOT-1-HARI-$a" on "/ip hotspot user remove [find name=$a];
/ip hotspot host remove [find mac-address=$b];
/ip hotspot active remove [find mac-address=$b];
/ip hotspot cookie remove [find mac-address=$b];
/system scheduler remove [find name=offinet-PAKET-HOTSPOT-1-HARI-$a]"]}

Untuk Paket WiFi yang lainnya sama saja hanya beda di kode script nya saja sbb :

PAKET-HOTSPOT-1-HARI-MH

:put (",,0,,,noexp,Enable,"); [:local mac $"mac-address"; /ip hotspot user set mac-address=$mac [find where name=$user]]
local a $user;
local b $"mac-address";
if ([len [/system scheduler find name="offinet-PAKET-HOTSPOT-1-HARI-MH-$a"]] = 0) do={[
/system scheduler add interval=1d name="offinet-PAKET-HOTSPOT-1-HARI-MH-$a" on "/ip hotspot user remove [find name=$a];
/ip hotspot host remove [find mac-address=$b];
/ip hotspot active remove [find mac-address=$b];
/ip hotspot cookie remove [find mac-address=$b];
/system scheduler remove [find name=offinet-PAKET-HOTSPOT-1-HARI-MH-$a]"]}
/tool fetch url="https://api.telegram.org/bot965817049:AAF1gfddQovWwMnaOLLS-Mf2tq95FjH85xs/sendMessage?chat_id=102re85791&text=MASUK : $user $address" keep-result=no

PAKET-HOTSPOT-1-HARI-ND

:put (",,0,,,noexp,Enable,"); [:local mac $"mac-address"; /ip hotspot user set mac-address=$mac [find where name=$user]]
local a $user;
local b $"mac-address";
if ([len [/system scheduler find name="offinet-PAKET-HOTSPOT-1-HARI-ND-$a"]] = 0) do={[
/system scheduler add interval=1d name="offinet-PAKET-HOTSPOT-1-HARI-ND-$a" on "/ip hotspot user remove [find name=$a];
/ip hotspot host remove [find mac-address=$b];
/ip hotspot active remove [find mac-address=$b];
/ip hotspot cookie remove [find mac-address=$b];
/system scheduler remove [find name=offinet-PAKET-HOTSPOT-1-HARI-ND-$a]"]}
/tool fetch url="https://api.telegram.org/bot965817049:AAF1g0A0frdWwMnaOLLS-Mf2tq95FjH85xs/sendMessage?chat_id=10we585791&text=MASUK : $user $address" keep-result=no

PAKET-HOTSPOT-1-JAM

:put (",,0,,,noexp,Enable,"); [:local mac $"mac-address"; /ip hotspot user set mac-address=$mac [find where name=$user]]
local a $user;
local b $"mac-address";
if ([len [/system scheduler find name="offinet-PAKET-HOTSPOT-1-JAM-$a"]] = 0) do={[
/system scheduler add interval=1h name="offinet-PAKET-HOTSPOT-1-JAM-$a" on "/ip hotspot user remove [find name=$a];
/ip hotspot host remove [find mac-address=$b];
/ip hotspot active remove [find mac-address=$b];
/ip hotspot cookie remove [find mac-address=$b];
/system scheduler remove [find name=offinet-PAKET-HOTSPOT-1-JAM-$a]"]}

PAKET-HOTSPOT-7-HARI

:put (",,0,,,noexp,Enable,"); [:local mac $"mac-address"; /ip hotspot user set mac-address=$mac [find where name=$user]]
local a $user;
local b $"mac-address";
if ([len [/system scheduler find name="offinet-PAKET-HOTSPOT-7-HARI-$a"]] = 0) do={[
/system scheduler add interval=7d name="offinet-PAKET-HOTSPOT-7-HARI-$a" on "/ip hotspot user remove [find name=$a];
/ip hotspot host remove [find mac-address=$b];
/ip hotspot active remove [find mac-address=$b];
/ip hotspot cookie remove [find mac-address=$b];
/system scheduler remove [find name=offinet-PAKET-HOTSPOT-7-HARI-$a]"]}

PAKET-HOTSPOT-14-HARI

:put (",,0,,,noexp,Enable,"); [:local mac $"mac-address"; /ip hotspot user set mac-address=$mac [find where name=$user]]
local a $user;
local b $"mac-address";
if ([len [/system scheduler find name="offinet-PAKET-HOTSPOT-14-HARI-$a"]] = 0) do={[
/system scheduler add interval=14d name="offinet-PAKET-HOTSPOT-14-HARI-$a" on "/ip hotspot user remove [find name=$a];
/ip hotspot host remove [find mac-address=$b];
/ip hotspot active remove [find mac-address=$b];
/ip hotspot cookie remove [find mac-address=$b];
/system scheduler remove [find name=offinet-PAKET-HOTSPOT-14-HARI-$a]"]}

PAKET-HOTSPOT-30-HARI

:put (",,0,,,noexp,Enable,"); [:local mac $"mac-address"; /ip hotspot user set mac-address=$mac [find where name=$user]]
local a $user;
local b $"mac-address";
if ([len [/system scheduler find name="offinet-PAKET-HOTSPOT-30-HARI-$a"]] = 0) do={[
/system scheduler add interval=30d name="offinet-PAKET-HOTSPOT-30-HARI-$a" on "/ip hotspot user remove [find name=$a];
/ip hotspot host remove [find mac-address=$b];
/ip hotspot active remove [find mac-address=$b];
/ip hotspot cookie remove [find mac-address=$b];
/system scheduler remove [find name=offinet-PAKET-HOTSPOT-30-HARI-$a]"]}

PAKET-HOTSPOT-KOPI-PLUS

:put (",,0,,,noexp,Enable,"); [:local mac $"mac-address"; /ip hotspot user set mac-address=$mac [find where name=$user]]
local a $user;
local b $"mac-address";
if ([len [/system scheduler find name="offinet-PAKET-HOTSPOT-KOPI-PLUS-$a"]] = 0) do={[
/system scheduler add interval=2h name="offinet-PAKET-HOTSPOT-KOPI-PLUS-$a" on "/ip hotspot user remove [find name=$a];
/ip hotspot host remove [find mac-address=$b];
/ip hotspot active remove [find mac-address=$b];
/ip hotspot cookie remove [find mac-address=$b];
/system scheduler remove [find name=offinet-PAKET-HOTSPOT-KOPI-PLUS-$a]"]}

PAKET-HOTSPOT-RUMAHAN

:put (",,0,,,noexp,Enable,No,Simple,,,,,,,");[:local mac $"mac-address"; /ip hotspot user set mac-address=$mac [find where name=$user]]
local a $user;
local b $"mac-address";
if ([/ip hotspot user get [find name="$a"] comment] = "") do={[
/ip hotspot user remove [find name=$b];
/ip hotspot user set [find name=$a] comment=$a mac-address=$b name=$b password="123456789";
/system scheduler add name=$b interval="00:00:02" on "/ip hotspot active remove [find mac-address=$b];
/ip hotspot host remove [find mac-address=$b];
/ip hotspot cookie remove [find mac-address=$b];
/system scheduler remove [find name=$b]"]}

PAKET-HOTSPOT-TEAM

:put (",,0,,,noexp,Enable,No,Simple,,,,,,,");[:local mac $"mac-address"; /ip hotspot user set mac-address=$mac [find where name=$user]]
local a $user;
local b $"mac-address";
if ([/ip hotspot user get [find name="$a"] comment] = "") do={[
/ip hotspot user remove [find name=$b];
/ip hotspot user set [find name=$a] comment=$a mac-address=$b name=$b password="123456789";
/system scheduler add name=$b interval="00:00:02" on "/ip hotspot active remove [find mac-address=$b];
/ip hotspot host remove [find mac-address=$b];
/ip hotspot cookie remove [find mac-address=$b];
/system scheduler remove [find name=$b]"]}

Setup Hotspot – User Profiles – IP Binding

Setup Simple Queues

Setup Queue Tree

Setup Scheduler

Demikian semoga bermanfaat. Jika ada yang keliru atau kurang, nanti deh om saya update lagi kedepannya untuk post ini, oke. ( Pipih Pirmansyah )

Comment

Leave a Reply

Your email address will not be published. Required fields are marked *

Artikel terkait lainnya