by

Cara Setting Membuat Paket WiFi Hotspot Voucheran Paket Siang (06.00-18.00) dan Paket Malam (18.00-06.00)

Langsung Viral dot com – Untuk informasi bahwa Cara yang dijelaskan di bawah ini adalah sudah Sukses Berhasil kami ujicoba karena memang kami tidak akan membuat artikel mikrotik yang memang tidak berhasil alias bohong alias hoax. Jadi setiap artikel mikrotik di Langsung Viral dot com adalah sudah sukses berhasil kami ujicoba dulu, baru di share ke om semuanya.

Kali ini saya akan share : Bagaimana Cara Membuat Paket WiFi Hotspot Voucheran Paket Siang dan Paket Malam.

Untuk Paket Siang adalah si WiFi hanya bisa aktif antara jam 6 pagi sampai jam 6 sore (magrib). Jadi jika orang mencoba me login kan di luar jam itu maka akan error.

Lalu untuk Paket Malam nya, si voucher wifi, hanya bisa aktif dari jam 6 magrib sampai jam 6 pagi di hari berikut nya. Jika orang mencoba meng aktifkan voucher di luar jam itu, maka akan error.

Oke Lanjut Om :

Untuk itu, kita akan buat dulu peraturan, untuk settingan waktu nya :

A. PAKET-HOTSPOT-SIANG-6-18

WiFi Hidup mulai jam : 05.55 (sengaja tidak pas jam 6, karena jam 6 adalah nanti untuk rule di PAKET-HOTSPOT-MALAM-18-6 – tujuannya agar tidak terlalu berat mikrotik karena bekerja pada waktu bersamaan.

WiFi Mati mulai jam : 18.05 (kenapa dilebihkan 5 menit? , karena kebetulan di saya, pada jam 18.00 adalah sudah ada jadwal mati ether5, jadi agar mikrotik tidak berat kerja nya, tidak numpuk kerjaan dia (mikrotik) pada jam 18.00 tersebut.

Data dihapus dari mikrotik pada jam : 18.10.

B. PAKET-HOTSPOT-MALAM-18-6

WiFi Hidup mulai jam : 17.55 (ini saya kurangi 5 menit, tidak pas jam 18.00, karena pada jam 18.00 memang sudah ada jadwal mati ether5 tersebut diatas khan o, jadi agar mikrotik kita kerja rodi, kasihan jika banyak kerjaan dilakukan pada waktu bersamaan.

WiFi Mati mulai jam : 06.00 (hari besok nya) – kita set jam 06.00 pas karena tidak ada jadwal lain pada jam 6 pagi tsb.

Data dihapus dari mikrotik pada jam : 06.05

Sip beres dalam menentukan target jam.

Jadi, sebagaimana terlihat diatas, kita harus membuat dua buah user profiles baru, yang kita beri nama :
– “PAKET-HOTSPOT-SIANG-6-18” dan
– “PAKET-HOTSPOT-MALAM-18-6”.

Dan inilah step by step cara setting nya :

1. Om buat dulu si masing-masing paket tersebut yaitu : PAKET-HOTSPOT-SIANG-6-18 dan PAKET-HOTSPOT-MALAM-18-6.

Caranya masuk ke Winbox – ke menu IP – Hotspot – User Profiles

Add – lihat contoh berikut ini :

PERTAMA :

Untuk PAKET-HOTSPOT-SIANG-6-18

Lalu masuk ke Tab Script dan input data berikut ini :

ON LOGIN

:put (",,0,,,noexp,Enable,"); [:local mac $"mac-address"; /ip hotspot user set mac-address=$mac [find where name=$user]]
local a $user;
local b $"mac-address";
if ([len [/system scheduler find name="offinet-PAKET-HOTSPOT-SIANG-6-18-$a"]] = 0) do={[
/system scheduler add interval=1d name="offinet-PAKET-HOTSPOT-SIANG-6-18-$a" start-time="18:10:00" on "/ip hotspot user remove [find name=$a];
/ip hotspot host remove [find mac-address=$b];
/ip hotspot active remove [find mac-address=$b];
/ip hotspot cookie remove [find mac-address=$b];
/system scheduler remove [find name=offinet-PAKET-HOTSPOT-SIANG-6-18-$a]"]}
/tool fetch url="https://api.telegram.org/bot874525324:AAF1g0A0QovWwMnaOLLS-CjUju52f5rrf5f/sendMessage?chat_id=1854215252&text=MASUK : $user $address" keep-result=no

ON LOGOUT

/tool fetch url="https://api.telegram.org/bot874525324:AAF1g0A0QovWwMnaOLLS-CjUju52f5rrf5f/sendMessage?chat_id=1854215252&text=KELUAR : $user $address" keep-result=no

Berikut ini penampakan nya :

KEDUA :

PAKET-HOTSPOT-MALAM-18-6

Lalu masuk ke Tab Script dan input data berikut ini :

ON LOGIN

:put (",,0,,,noexp,Enable,"); [:local mac $"mac-address"; /ip hotspot user set mac-address=$mac [find where name=$user]]
local a $user;
local b $"mac-address";
if ([len [/system scheduler find name="offinet-PAKET-HOTSPOT-MALAM-18-6-$a"]] = 0) do={[
/system scheduler add interval=1d name="offinet-PAKET-HOTSPOT-MALAM-18-6-$a" start-time="06:05:00" on "/ip hotspot user remove [find name=$a];
/ip hotspot host remove [find mac-address=$b];
/ip hotspot active remove [find mac-address=$b];
/ip hotspot cookie remove [find mac-address=$b];
/system scheduler remove [find name=offinet-PAKET-HOTSPOT-MALAM-18-6-$a]"]}
/tool fetch url="https://api.telegram.org/bot874525324:AAF1g0A0QovWwMnaOLLS-CjUju52f5rrf5f/sendMessage?chat_id=1854215252&text=MASUK : $user $address" keep-result=no

ON LOGOUT

/tool fetch url="https://api.telegram.org/bot874525324:AAF1g0A0QovWwMnaOLLS-CjUju52f5rrf5f/sendMessage?chat_id=1854215252&text=KELUAR : $user $address" keep-result=no

Berikut ini penampakan nya :

Ok Om, kita sudah beres urusan membuat User Profile nya.

Langkah Selanjutnya, kita harus membuat Empat Buah Scheduler, dimana si empat scheduler tersebut berfungsi untuk mengatur waktu Enable dan Disable voucher-vouhcer paket siang dan paket malam.

Jadi nanti akan terbentuk 4 buah sceduler, contoh sbb :

ON-Profile-PAKET-HOTSPOT-SIANG-6-18
OFF-Profile-PAKET-HOTSPOT-SIANG-6-18
serta
ON-Profile-PAKET-HOTSPOT-MALAM-18-6
OFF-Profile-PAKET-HOTSPOT-MALAM-18-6

Nah, sekarang, Settingan-settingan untuk masing-masing ke empat scheduler tsb :

Settingan Scheduler : ON-Profile-PAKET-HOTSPOT-SIANG-6-18

dimana, on event nya di isi :
/ip hotspot user enable [find where profile=PAKET-HOTSPOT-SIANG-6-18]

Settingan Scheduler : OFF-Profile-PAKET-HOTSPOT-SIANG-6-18

dimana, on event nya di isi :
/ip hotspot user disable [find where profile=PAKET-HOTSPOT-SIANG-6-18]

Settingan Scheduler : ON-Profile-PAKET-HOTSPOT-MALAM-18-6

dimana, on event nya di isi :
/ip hotspot user enable [find where profile=PAKET-HOTSPOT-MALAM-18-6]

Settingan Scheduler : OFF-Profile-PAKET-HOTSPOT-MALAM-18-6

dimana, on event nya di isi :
/ip hotspot user disable [find where profile=PAKET-HOTSPOT-MALAM-18-6]

Oke om, Scheduler sudah beres sukses terbuat, jadi hanya 4 scheduler diatas.

Kalau sudah jadi, nanti ke empat scheduler itu akan tampak begini om (yang saya kasih stabilo warna kuning di bawah ini) :

Kalau Nggak Mau Ribet, terima beres, ini saya kasih kan script nya, untuk ke empat schedule diatas yaitu :
ON-Profile-PAKET-HOTSPOT-SIANG-6-18
OFF-Profile-PAKET-HOTSPOT-SIANG-6-18
serta
ON-Profile-PAKET-HOTSPOT-MALAM-18-6
OFF-Profile-PAKET-HOTSPOT-MALAM-18-6

Tinggal Om copas di New Terminal :

/system scheduler
add interval=1d name=OFF-Profile-PAKET-HOTSPOT-SIANG-6-18 on-event=\
"/ip hotspot user disable [find where profile=PAKET-HOTSPOT-SIANG-6-18]" \
policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \
start-date=dec/28/2019 start-time=18:05:00
add interval=1d name=ON-Profile-PAKET-HOTSPOT-SIANG-6-18 on-event=\
"/ip hotspot user enable [find where profile=PAKET-HOTSPOT-SIANG-6-18]" \
policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \
start-date=dec/28/2019 start-time=05:55:00
add interval=1d name=OFF-Profile-PAKET-HOTSPOT-MALAM-18-6 on-event=\
"/ip hotspot user disable [find where profile=PAKET-HOTSPOT-MALAM-18-6]" \
policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \
start-date=dec/28/2019 start-time=06:00:00
add interval=1d name=ON-Profile-PAKET-HOTSPOT-MALAM-18-6 on-event=\
"/ip hotspot user enable [find where profile=PAKET-HOTSPOT-MALAM-18-6]" \
policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \
start-date=dec/28/2019 start-time=17:55:00

SELANJUTNYA :

2. Setelah membuat dan me nyetting dua buah user profiles serta membuat dan setting empat buah scheduler nya, maka sekarang kita membuat voucher nya.

Bisa langsung pake mikrotik atau pake generate mikhmon.

Oke, kita coba pake generate mikhmon saja ya om.

Lihat cara generate nya – contoh kita buat yang paket siang saja, karena kebetulan saat ini siang :

Keterangan : Time Limit, kosongin saja om, karena kita akan atur nya di scheduler langsung.

Berikut Ini om hasilnya, sudah ter buat 4 voucher kan,, karena kita generate nya 4 saja.

Sudah beres om. tinggal ujicoba.

Oke kita ujicoba loginkan voucher “ps261srt33” ya

Nah, jika sudah sukses me login kan si “ps261srt33” maka nanti akan muncul sebuah scheduler baru yang mengarah ke si voucher “ps261srt33” tersebut.

Ini buktinya :

Keterangan :

Perhatikan dari mulai nama nya dan jam nya kapan dia akan otomatis di hapus dari mikrotik, dia akan mulai dihapus pada jam 18:10:00 tanggal 26 januari 2020 (hari ini), saya meng aktifkan nya barusan om jam 17.10 pagi.. ini kan ceritanya paket siang. Jadi habis nya dan akan di hapus nya nanti jam 18.10. bisa om lihat dan perhatikan sendiri ss diatas.

Tambahan :

Ketika siang hari (6-18), maka voucher-voucher paket malam, dia otomatis dalam posisi ter disable om. Lihat ss berikut :

Begitu pula sebaliknya, pada malam hari nanti yaitu jam 18-6 maka semua voucher-voucher pada paket siang akan otomatis ter disable, sehingga jika ada orang yang usil – yang nyoba-nyoba login voucher bukan pada waktunya, dia akan error.

Demikian, semoga bermanfaat. (LV – PP)

Comment

Leave a Reply

Your email address will not be published. Required fields are marked *

6 comments

  1. Kang aq tu g pakai mikhmon cmn pakai pakai usermanager, apakah rule ini juga bisa diterapkan kalau kita pakai usermanager?

    1. untuk di aplikasin di userman, sama kang, saya juga belum men try nya.
      tapi jika hal-hal data yang di inputkan di mikmon sesuai penjelasan diatas adalah ada tersedia di userman, maka saya kira bisa saja ini diaplikasikan ke yg pake userman, karena baik userman dan atau mikhmon, muaranya sama saja yaitu ke mesin mikrotik.
      demikian tanggapan saya.
      makasih.

Artikel terkait lainnya