by

Catatan Setting Monitoring User dan AP WiFi Hotspot Voucheran menggunakan Bot Telegram

Langsung Viral dot com – Untuk Cara Pembuatan Bot Telegram, saya rekomendasikan om untuk membacanya di suatu Artikel di blog lain yaitu ini “Membuat Bot Telegram Untuk Monitoring Status Access Point Hotspot” (untuk Cara Monitoring AP memakai Bot Telegram)

Juga, om harus memahami artikel ini : Monitoring User Yang Sedang Login ke Mikrotik dengan Bot Telegram (itu untuk cara monitoring User-user voucher dll yang ada di WiFi Hotspot kita menggunakan Bot Telegram juga.

Catatan Penting !!!

Oh, ya, jika setelah mengikuti Anjuran di kedua artikel diatas, Bot Telegram Om masih error (tidak jalan) bahkan memunculkan error :

{"ok":false,"error_code":403,"description":"Forbidden: bot was blocked by the user"}

Maka itu artinya, Om harus di Add dulu si Bot Telegram yang telah om buat tersebut ke suatu Group Telegram yang Om buat (maksudnya Om Owner Group Telegram baru tersebut). Maka setelah si akun Bot Telegram di masukkan ke dalam Group Tele punya om, maka nanti akan jalan dan mulai berfungsi si bot nya (tidak memunculkan error tsb ketika di test di browser).

Berikut ini penampakan yang menunjukkan bahwa akun Bot Telegram saya sudah saya masukkan ke dalam Group saya : (saya bikin dua bot om), yaitu untuk (1) Bot Telegram Monitoring User dan (2) Bot Telegram Monitoring AP.

Oke, Jadi, di post artikel ini, saya lebih ke Catatan Backup settingan script nya saja, jadi Om akan paham apa yang di ceritakan di artikel saya ini setelah om, baca-baca dan memahami artikel di blog orang lain tersebut diatas.

A. Script untuk Monitoring User Hotspot Voucheran

Cara penerapannya, Om copas saja ke IP – Hotspot – tab User Profiles

Lalu, om pilih user profile mana yang akan di monitor.

Om masuk ke Tab Scripts, dan isi nya di On Login serta di On Logout

Ini contoh Script nya, satu saja ya om :

Pada On Login :

/tool fetch url="https://api.telegram.org/botTOKEN-OM-PASTE-DISINI/sendMessage?chat_id=CHAT-ID-OM-PASTE-DISINI&text=MASUK : $user $address" keep-result=no

Contoh Penerapan Real nya di On Login :

/tool fetch url="https://api.telegram.org/bot452123625:FFC58c0A0QovWwMnaOLLS-Mf2tq95Dsd585/sendMessage?chat_id=5485632158&text=MASUK : $user $address" keep-result=no

lalu, pada On Logut :

/tool fetch url="https://api.telegram.org/botTOKEN-OM-PASTE-DISINI/sendMessage?chat_id=CHAT-ID-OM-PASTE-DISINI&text=KELUAR : $user $address" keep-result=no

Contoh Penerapan Real nya di On Logout :

/tool fetch url="https://api.telegram.org/bot452123625:FFC58c0A0QovWwMnaOLLS-Mf2tq95Dsd585/sendMessage?chat_id=5485632158&text=KELUAR : $user $address" keep-result=no

Hasilnya nanti, seperti berikut ini :

B. Script untuk Monitoring AP (Acceess Point) Hotspot Voucheran

Setting nya, di Tools – Netwatch

Om harus memahami dulu artikel ini agar paham cara setting dasar nya : “Cara Setting di Netwatch Mikrotik untuk Memantau AP Hotspot Mana yang Sedang UP atau Sedang DOWN Internet nya

Jika om tidak memahami artikel diatas, maka akan bingung juga, jika om belum pernah lakukan itu.

Oke, untuk monitoring AP, kita gunakan Bot Telegram Terpisah, jadi tidak menggunakan bot telegram yang buat mantau User diatas (di point A).

Mengapa saya pisah? – karena agar mudah management nya dan di lihatnya enak saja om, tapi bisa saja dan tidak apa-apa digabung juga dengan monitoring User siiiii.

Catatan penting : untuk beda bot telegram, nantinya yang beda itu adalah Token nya saja, sedangkan chat ID nya adalah tetap saja sama, pakai yang itu-itu juga, baik untuk Monitoring User pun Monitoring AP.

Berikut ini adalah sample punya saya, saya ambil satu saja ya om, sama saja koq. Ini hanya untuk contoh :

Keterangan dan Penjelasan :

Untuk di Tab UP, kita isi ini :

:local CHID "PASTE-CHAT-ID-OM-DISINI";
:local BotID "PASTE-TOKEN-OM-DISINI";
:local HostStatus "NYAMBUNG";

:local message "AP Saung Salira 1 : $host - $HostStatus";

/tool fetch url="https://api.telegram.org/bot$BotID/sendmessage\?chat_id=$CHID&text=$message";

Contoh Penerapan Real nya, untuk di tab UP :

:local CHID "6125945213";
:local BotID "1526325625:ccADF6ByXXOxB3u_UJYUHYH2cB8tgk12CD4x5dX";
:local HostStatus "NYAMBUNG";

:local message "AP Saung Salira 1 : $host - $HostStatus";

/tool fetch url="https://api.telegram.org/bot$BotID/sendmessage\?chat_id=$CHID&text=$message";

Kemudian, Untuk di Tab DOWN, kita isi ini :

:local CHID "PASTE-CHAT-ID-OM-DISINI";
:local BotID "PASTE-TOKEN-OM-DISINI";
:local HostStatus "PUTUS";

:local message "AP Saung Salira 1 : $host - $HostStatus";

/tool fetch url="https://api.telegram.org/bot$BotID/sendmessage\?chat_id=$CHID&text=$message";

Contoh Penerapan Real nya, untuk di tab DOWN :

:local CHID "6125945213";
:local BotID "1526325625:ccADF6ByXXOxB3u_UJYUHYH2cB8tgk12CD4x5dX";
:local HostStatus "PUTUS";

:local message "AP Saung Salira 1 : $host - $HostStatus";

/tool fetch url="https://api.telegram.org/bot$BotID/sendmessage\?chat_id=$CHID&text=$message";

Hasilnya nanti akan seperti berikut ini :

Info Tambahan :

Jika Om mau yang sistem lengkap, maka silahkan bisa gunakan yang versi – yang di di share om Pradipta Wardifi.

Berikut ini :

ON LOGIN

:put (",,0,,,,Disable,");{:local mac $"mac-address";
:local Mwp [/ip hotspot user get [find name="$user"] uptime];
:local dvc [/ip dhcp-server lease get [find mac-address="$mac"] host-name];
:local Mpkt [/ip hotspot user get [find name="$user"] profile];
:local Md [/ip hotspot user get [find name="$user"] bytes-in];
:local Mu [/ip hotspot user get [find name="$user"] bytes-out];
:local limit [/ip hotspot user get [find name="$user"] limit-bytes-total];
:local totq [(($limit)/1048576)];
:local Mt [((($Md)+($Mu))/1048576)];
:local sisa [($totq-($Md+$Mu)/1048576)];
:local exp [/ip hotspot user get [find name="$user"] comment];
:local Ma [/ip hotspot active print count-only];
/tool fetch url="https://api.telegram.org/bot(TOKEN API)/sendMessage?chat_id=(CHAT ID)&text====>> MASUK $user %0A- IP Address : $address%0A- Mac Address : $mac%0A- Device : $dvc%0A- Paket : $Mpkt%0A- Waktu Terpakai : $Mwp%0A- Jumlah Kuota : $totq Mb%0A- Kuota Terpakai : $Mt Mb%0A- Sisa Kuota : $sisa Mb%0A- Expired : $exp%0A- Users Yang Online : $Ma Users" mode=http keep-result=no}

ON LOGOUT

{:local mac $"mac-address";
:local Mwp [/ip hotspot user get [find name="$user"] uptime];
:local dvc [/ip dhcp-server lease get [find mac-address="$mac"] host-name];
:local Mpkt [/ip hotspot user get [find name="$user"] profile];
:local Md [/ip hotspot user get [find name="$user"] bytes-in];
:local Mu [/ip hotspot user get [find name="$user"] bytes-out];
:local limit [/ip hotspot user get [find name="$user"] limit-bytes-total];
:local totq [(($limit)/1048576)];
:local Mt [((($Md)+($Mu))/1048576)];
:local sisa [($totq-($Md+$Mu)/1048576)];
:local exp [/ip hotspot user get [find name="$user"] comment];
:local Ma [/ip hotspot active print count-only];
/tool fetch url="https://api.telegram.org/bot(TOKEN API)/sendMessage?chat_id=(CHAT ID)&text=<<=== KELUAR $user %0A- IP Address : $address%0A- Mac Address : $mac%0A- Device : $dvc%0A- Paket : $Mpkt%0A- Waktu Terpakai : $Mwp%0A- Jumlah Kuota : $totq Mb%0A- Kuota Terpakai : $Mt Mb%0A- Sisa Kuota : $sisa Mb%0A- Expired : $exp%0A- Users Yang Online : $Ma Users" mode=http keep-result=no}

Demikian, semoga bermanfaat. (LV – PP)

Comment

Leave a Reply

Your email address will not be published. Required fields are marked *

Artikel terkait lainnya