Cara Setting Voucher WiFi Paket Tempat Wisata, Hanya Bisa Aktif Antara Jam 08.00 s.d Jam 16.00

Langsung Viral dot com – Kita misalnya punya tempat yang unik kecil-kecilan. Maka jadilah kita jadikan tempat wisata minimalis. Dah begitu saja lah sample cerita nya.

Sumber Script : dari Om Yasser Wolter Isa

Nah, di tempat Wisata kita itu, ada fasilitas WiFi Gratis nya.

Jadi WiFi Gratis nya Hanya bisa Aktif antara Jam 8 pagi sampai dengan jam 4 sore (Jam 16.00) karena memang Jam buka tempat wisata kita adalah Jam Segitu.

Jadi pas Jam 16.00 itu maka si Voucher WiFi (yang pernah aktif, dan atau yang sedang aktif di hari itu) akan langsung di hapus oleh sistem mikrotik menjadi tak berbekas lagi. Maka secara otomatis semua orang yang sedang memakai Voucher WiFi tersebut menjadi terhenti seketika semua nya. Jos kan om ?

Juga ketika masuk jam 16.00 itu, semua voucher WiFi yang mengarah ke Profile Hotspot paket Tempat Wisata tersebut akan otomatis di Disable kan si semua voucher wifi nya.

Fungsi nya di disable semua voucher wifi paket tempat wisata adalah agar orang-orang tidak bisa login ke WiFi menggunakan voucher wifi paket tempat wisata, karena kondisi semua voucher wifi nya sudah di disable. ARTINYA dan Maksudnya adalah Selain di Antara Jam 8 pagi sampai jam 4 sore, maka si voucher tidak akan pernah bisa di login kan, dia akan error, karena memang sudah di disable oleh sistem jika diluar jam 8 pagi – 4 sore. JOS om.

Keterangan : yang di disable itu adalah khusus untuk voucher-voucher yang dikelola oleh si User Profile Paket Tempat Wisata saja yaaaa om (yang di disable itu), sedangkan voucher-voucher di luar paket Wisata, ya tetap saja lah, jalan (tidak di disable).

Kita lanjut, cerita nya :

Lalu, nanti pada Jam 8 pagi besoknya, maka si semua voucher akan di enable kan lagi secara otomatis, sehingga orang-orang bisa menggunakan kembali / bisa login wifi menggunakan voucher wifi paket tempat wisata itu.

KOLAM SALIRA
Tempat Botram & Ngasih Makan Ikan
WiFi Gratis Anti Lag, Anti Lelet
Buka Jam : 08.00 – 16.00
Iuran Perawatan Tempat : Rp.2.500,-/org.

Nah, berikut ini adalah cara setting nya.

1. Buat User Profile nya

2. Lakukan Generate Voucher nya yang mengarah ke User Profile diatas

3. Ini contoh hasil generate voucher wifi tadi diatas (3 voucher)

3. Masukan script berikut ini pada On Login si User Profile diatas:

local a $user;
local b $"mac-address";
if ([len [/system scheduler find name="offinet-PAKET-KOLAM-SALIRA-1-$a"]] = 0) do={[
/system scheduler add interval=1d name="offinet-PAKET-KOLAM-SALIRA-1-$a" start-time="16:00:00" on "/ip hotspot user remove [find name=$a];
/ip hotspot host remove [find mac-address=$b];
/ip hotspot active remove [find mac-address=$b];
/ip hotspot cookie remove [find mac-address=$b];
/system scheduler remove [find name=offinet-PAKET-KOLAM-SALIRA-1-$a]"]}

Ini penampakan nya :

4.Lalu paste script dibawah di New Terminal Winbox, ini dia code nya om:

/system scheduler
add name="ON-Profile-PAKET-KOLAM-SALIRA-1" start-time="08:00:00" interval="1d00:00:00" on-event="/ip hotspot user enable [find where profile=PAKET-KOLAM-SALIRA-1]"
add name="OFF-Profile-PAKET-KOLAM-SALIRA-1" start-time="16:00:00" interval="1d00:00:00" on-event="/ip hotspot user disable [find where profile=PAKET-KOLAM-SALIRA-1]"

Nanti hasilnya akan ter create dua buah Scheduler, seperti di bawah ini :

5. Oke, sudah beres om. Tadi sudah saya ujicoba kan salah-satu voucher nya, ini dia data nya. Kode wifi : ms2812ruf89

6. Jika sudah di login kan, maka nanti di Scheduler akan ter create sebuah scheduler baru, yaitu yang mengarah ke si data voucher “ms2812ruf89” tersebut.

Ini penampakannya :

Keterangan :

Si Scheduler “offinet-PAKET – KOLAM-SALIRA-1 – ms2812ruf89” ini berfungsi untuk :

/ip hotspot user remove [find name=ms2812ruf89];
Menghapus Voucher ms2812ruf89 dari Mikrotik.

/ip hotspot host remove [find mac-address=*****0E:40:24];
Menghapus Tampilan Voucher ms2812ruf89 dari IP – Hotspot Tab Host, Mikrotik.

/ip hotspot active remove [find mac-address=*****:0E:40:24];
Menghapus Tampilan Voucher ms2812ruf89 dari IP – Hotspot Tab Actives, Mikrotik.

/ip hotspot cookie remove [find mac-address=*****:0E:40:24];
Menghapus Tampilan Voucher ms2812ruf89 dari IP – Hotspot Tab Cookies, Mikrotik.

/system scheduler remove [find name=offinet-PAKET-KOLAM- SALIRA-1-ms2812ruf89]
Menghapus si Scheduler “offinet-PAKET-KOLAM- SALIRA-1-ms2812ruf89” dari System – Scheduler, Mikrotik.

7. Sudah Beres Om.

Demikian, semoga bermanfaat. (LV – PP)

Tags: #Aktif #Cara #Paket #Setting #Tempat Wisata #Voucher #WiFi