by

Cara Setting Agar Semua Voucher WiFi Hotspot yang Sedang dan Masih Aktif, Dihapus Otomatis pada Jam 05.00 Pagi

Langsung Viral dot com – Misalnya, kita punya Usaha Warkop dengan Fasilitas Free WiFi (WiFi Gratis).

Lalu kita menerapkan sistem Voucher WiFi untuk diberikan ke setiap pelanggan yang telah beli Makanan atau Minuman dengan minimum Rupiah sebesar Rp. 3.000,-

Artinya, orang yang Jajan nya di bawah Rp. 3.000,- itu tidak akan dikasih Voucher WiFi Gratis. Titik. Itu hanya contoh saja ya om.

Nah, Warkop kita itu Buka Full 24 Jam.

Cara pada Sistem Script ini adalah Tanpa Validity juga Tanpa Time Limit

Lalu Peraturan di Sistem Voucher WiFi nya adalah bahwa Voucher WiFi tersebut akan di hapus secara Otomatis oleh Sistem Mikrotik pada Jam 05.00 Pagi.

Jadi Jam berapa pun pelanggan Mulai Login nya, maka si voucher dia itu tetap saja akan di hapus oleh sistem pada jam 05.00 Pagi.

Misalnya, ada pelanggan yang Login Voucher WiFi nya jam 7 Pagi tanggal 27 Desember, maka Voucher dia akan di hapus pada jam 05.00 pagi tanggal tanggal 28 Desember (besok nya).

Lalu, contoh lain, ada pelanggan yang Login Voucher nya pada jam 23.00 malam, tanggal 27 Desember, maka tetap saja si voucher nya akan di hapus oleh sistem pada jam 05.00 pagi hari, tanggal 28 desember (besoknya).

Kemudian, ada juga ternyata pelanggan yang Login nya Jam 04.00 pagi tanggal 28 Desember, maka yaaa tetap saja si voucher nya akan di hapus pada jam 05.00 pagi tanggal 28 desember.

Jadi, pada intinya, jam berapapun si pelanggan login nya, maka semua voucher wifi yang di telah aktifkan (sedang aktif / pernah aktif) akan di hapus secara otomatis semuanya pada jam 05.00 pagi hari.

Nah, inilah cara setting di mikrotik nya om :

Sumber dari Om : Yasser Wolter Isa

1. Setting User Profile baru seperti ini

2. Generate User, seperti ini

3. Dan ini contoh hasil generate voucher nya

4. Selanjutnya kita masukkan script berikut ini ke dalam User Profile yang akan di bidik. Di bagian On Login nya :

Berikut ini code nya (saya hanya untuk sample saja, memakai Jam 17.50 —- bukan seperti di judul jam 5 pagi, heee..)

local a $user;
local b $"mac-address";
if ([len [/system scheduler find name="$a"]] = 0) do={[
/system scheduler add interval=1d name=$a start-time="17:50:00" on "/ip hotspot user remove [find name=$a];
/ip hotspot host remove [find mac-address=$b];
/ip hotspot active remove [find mac-address=$b];
/ip hotspot cookie remove [find mac-address=$b];
/system scheduler remove [find name=$a]"]}

5. Dan ini voucher yang akan di ujicoba

Voucher : ws2712and46

6. Dan setelah di login kan, maka kita akan dapat Mac Address nya, jadi begini

Voucher : ws2712and46
MAC Address : xx:xx:xx:xx:40:24

7. Dan di IP – Hotspot – Tab Active sudah muncul

8. Di IP – Hotspot – Tab Hosts juga sudah muncul

9. Di IP – Hotspot – Tab Cookies juga sudah muncul

10. Di IP – DHCP Server – Tab Leases juga sudah muncul

MAAF Data di bawah, terpaksa pakai Data voucher lain untuk sample nya, karena keburu hilang si data voucher ws2712and46, karena tadi kan di set nya di del pada jam 17.50.

nah saya rubah lagi waktu delete di user profile nya menjadi ke jam 17.57. Hee…

Oke kita lanjut pake data voucher baru yaitu si “ws2712hhr75” – bukan lagi si “ws2712and46” karena sudah hilang om, terhapus otomatis karena tadi di set ke jam 17.50 siiii.. terlalu cepat tadi saya setting waktu untuk ujicoba nya. Heee..

11. Di System – Scheduler juga sudah muncul (secara otomatis) pas pelanggan sukses login voucher wifi nya :

Saya pake data sample voucher baru : “ws2712hhr75”

12. Setelah jam 17.57 lewat maka, :

Data si “ws2712hhr75” menjadi terhapus di IP – Hotspot – Tab :
– Active
– Hosts
– Cookies

Tapi kalau di IP – DHCP Server – Tab Leases sih masih ada.

Biarkan saja, nanti juga terhapus pas Expire After nya tersentuh.

Intinya, saya ingin tegaskan bahwa Script ini Lulus, Work, Berhasil.

Si Voucher menjadi Terhapus Tak berbekas di Jam yang kita inginkan. Tidak peduli client login nya jam berapa.

UPDATE :
Untuk beda hari, maka di script scheduler, harus di tambah : “interval=1d” = “1d 00:00:00” – Jangan di kosongkan.
Script diatas sudah saya tambah ada “interval=1d” nya. (walau di ilustrasi, tidak ada interval 1d nya.

Jadi, jika saya tulis ulang, maka di bawah ini adalah code script untuk di paste di user profile di kolom On Login nya saja. Untuk menghapus voucher pada jam 5 Pagi.

local a $user;
local b $"mac-address";
if ([len [/system scheduler find name="$a"]] = 0) do={[
/system scheduler add interval=1d name=$a start-time="05:00:00" on "/ip hotspot user remove [find name=$a];
/ip hotspot host remove [find mac-address=$b];
/ip hotspot active remove [find mac-address=$b];
/ip hotspot cookie remove [find mac-address=$b];
/system scheduler remove [find name=$a]"]}

Demikian, semoga bermanfaat. (LV – PP)

Comment

Leave a Reply

Your email address will not be published. Required fields are marked *

Artikel terkait lainnya