Setting PPPoE Sekaligus Hotspot WiFi pada Interface yang sama di Mikrotik Mikhmon

Langsung Viral dot com – Sekarang, Langsung Viral akan mencoba mencatat settingan penting untuk Bagaimana Cara kita Setting Jaringan PPPoE Sekaligus Jaringan Hotspot WiFi pada Interface yang sama di Mikrotik Mikhmon.

Jadi misalnya di Mikrotik Langsung Viral itu ada tiga ether di RB450G yang digunakan untuk Voucheran yaitu Ether 3, Ether 4 dan Ether 5, yang kemudian di Bridge kan, diberi nama Bridge1.

Nah bagaimana Cara agar ether-ether yang termasuk ke dalam Bridge1 tersebut adalah menjadi berfungsi juga untuk Service PPPoE. Jadi dalam satu Interface itu didalamnya ada service lain, dalam hal ini si Bridge1 awalnya adalah untuk Hotspot Voucheran. Nah, bagaimana agar si Bridge1 juga bisa digunakan / bisa di akses oleh pengguna PPPoE ?

Jadi ether-ether yang akan dibuat PPPoE itu adalah ether3, ether4, ether5, dimana ketiga ether tersebut tergabung ke dalam sistem bridge, dan dikasih nama bridge1.

Disini, Langsung Viral tidak membahas settingan Hotspot nya, tapi langsung ke Settingan PPPoE nya.

Inilah Step By Step nya :

Sebelumnya eksekusi dulu script part 4.5 om ega berikut ini : (tapi tentunya sesuaikan dengan data mikrotik dan data paket internet om, di bawah ini hanya contoh saja, settingan punya nya Warkop Salira – Warkop Free WiFi Anti Lag.

/ip firewall mangle
add action=mark-connection chain=postrouting comment="TOTAL ALL" \
connection-mark="!PORT SELAIN PORT UMUM ( GAME )" new-connection-mark=\
"TOTAL ALL" packet-mark="!ICMP DOWN" passthrough=yes
add action=mark-packet chain=forward connection-mark="TOTAL ALL" \
in-interface=ether1 new-packet-mark="DOWNLOAD ALL" passthrough=yes
add action=mark-packet chain=forward connection-mark="TOTAL ALL" \
new-packet-mark="UPLUAD ALL" out-interface=ether1 passthrough=yes
add action=mark-connection chain=postrouting comment=GAME dst-address-list=\
"IP GAME ONLINE" new-connection-mark="PORT SELAIN PORT UMUM ( GAME )" \
passthrough=yes
add action=mark-packet chain=forward connection-mark=\
"PORT SELAIN PORT UMUM ( GAME )" in-interface=ether1 new-packet-mark=\
"PORT SELAIN PORT UMUM(GAME) DOWN" passthrough=yes
add action=mark-packet chain=forward connection-mark=\
"PORT SELAIN PORT UMUM ( GAME )" new-packet-mark=\
"PORT SELAIN PORT UMUM(GAME) UP" out-interface=ether1 passthrough=yes
add action=mark-connection chain=postrouting comment=\
"MASUKAN PORT GAME KE TRAFICK BERAT JIKA 200k-999M" connection-mark=\
"PORT SELAIN PORT UMUM ( GAME )" connection-rate=200k-999M \
new-connection-mark="PORT BERAT" passthrough=yes
add action=mark-packet chain=forward connection-mark="PORT BERAT" \
in-interface=ether1 new-packet-mark="PORT BERAT DOWN" passthrough=yes
add action=mark-packet chain=forward connection-mark="PORT BERAT" \
new-packet-mark="PORT BERAT UP" out-interface=ether1 passthrough=yes
add action=mark-connection chain=postrouting comment=\
"KEMBALIKAN PORT BERAT KE GAME JIKA TRAFICK 0K-200K" connection-mark=\
"PORT BERAT" connection-rate=0-200k new-connection-mark=\
"PORT SELAIN PORT UMUM ( GAME )" passthrough=yes
add action=mark-connection chain=postrouting comment=icmp \
new-connection-mark=ICMP passthrough=yes protocol=icmp
add action=mark-packet chain=forward connection-mark=ICMP in-interface=\
ether1 new-packet-mark="ICMP DOWN" passthrough=yes
add action=mark-packet chain=forward connection-mark=ICMP new-packet-mark=\
"ICMP UP" out-interface=ether1 passthrough=yes
add action=mark-connection chain=postrouting comment=SOSMED dst-address-list=\
sosmed new-connection-mark=SOSMED passthrough=yes
add action=mark-packet chain=forward connection-mark=SOSMED in-interface=\
ether1 new-packet-mark="SOSMED DOWN" passthrough=yes
add action=mark-packet chain=forward connection-mark=SOSMED new-packet-mark=\
"SOSMED UP" out-interface=ether1 passthrough=yes
add action=mark-connection chain=postrouting comment=YOUTUBE \
dst-address-list=youtube.com new-connection-mark=YT passthrough=yes
add action=mark-packet chain=forward connection-mark=YT in-interface=\
ether1 new-packet-mark="YOUTUBE DOWN" passthrough=yes
add action=mark-packet chain=forward connection-mark=YT new-packet-mark=\
"YOUTUBE UP" out-interface=ether1 passthrough=yes

/queue tree
add max-limit=20M name="TRAFICK GLOBAL DOWN" parent=global queue=\
pcq-download-default
add max-limit=4M name="TRAFICK GLOBAL UP" parent=global queue=\
pcq-download-default
add name="1.youtube.com down" packet-mark="YOUTUBE DOWN" parent=\
"TRAFICK GLOBAL DOWN" queue=pcq-download-default
add name="1.youtube.com up" packet-mark="YOUTUBE UP" parent=\
"TRAFICK GLOBAL UP" queue=pcq-upload-default
add name="2.Sosmed down" packet-mark="SOSMED DOWN" parent=\
"TRAFICK GLOBAL DOWN" queue=pcq-download-default
add name="2.sosmed up" packet-mark="SOSMED UP" parent="TRAFICK GLOBAL UP" \
queue=pcq-upload-default
add name="3.all trafic up" packet-mark="UPLUAD ALL" parent=\
"TRAFICK GLOBAL UP" queue=pcq-download-default
add name="3.all trafic down" packet-mark="DOWNLOAD ALL" parent=\
"TRAFICK GLOBAL DOWN" queue=pcq-download-default
add name="4.berat down" packet-mark="PORT BERAT DOWN" parent=\
"TRAFICK GLOBAL DOWN" queue=pcq-download-default
add name="4.berat up" packet-mark="PORT BERAT UP" parent="TRAFICK GLOBAL UP" \
queue=pcq-download-default
add max-limit=20M name="1.SELAIN PORT UMUM RINGAN GAME ONLINE DOWN" \
packet-mark="PORT SELAIN PORT UMUM(GAME) DOWN" parent=global priority=1 \
queue=pcq-download-default
add max-limit=4M name="2.PORT SELAIN PORT UMUM(GAME) UP" packet-mark=\
"PORT SELAIN PORT UMUM(GAME) UP" parent=global priority=1 queue=\
pcq-upload-default
add name="4.ICMP DOWN" packet-mark="ICMP DOWN" parent=global priority=1
add name="5.ICMP UP" packet-mark="ICMP UP" parent=global priority=1

/queue simple
add max-limit=4M/20M name="1.SELAIN PORT UMUM RINGAN GAME ONLINE DOWN" \
packet-marks=\
"PORT SELAIN PORT UMUM(GAME) DOWN,PORT SELAIN PORT UMUM(GAME) UP" \
priority=1/1 queue=default/default target="10.5.50.0/24,10.5.51.0/24,192.168.10.0/24,"
add name="2.ICMP DOWNLOAD" packet-marks="ICMP DOWN,ICMP UP" priority=1/1 \
queue=default/default target="10.5.50.0/24,10.5.51.0/24,192.168.10.0/24,"
add max-limit=4M/20M name="ALL TRAFICK" packet-marks="SOSMED UP,SOSMED DOWN,YOUTUBE UP,YOUTUBE DOWN,UPLUAD ALL,DOWNLOAD ALL,PORT BERAT DOWN,PORT BERAT UP"\
priority=3/3 queue=pcq-upload-default/pcq-download-default target="10.5.50.0/24,10.5.51.0/24,192.168.10.0/24,"
add name="3.USER HOTSPOT&RUMAHAN" parent="ALL TRAFICK" priority=5/5 queue=\
default/default

/ip firewall address-list
add address=192.168.100.0/24 list="IP LOCAL"
add address=10.5.50.0/24 list="IP LOCAL"
add address=10.5.51.0/24 list="IP LOCAL"
add address=192.168.10.0/24 list="IP LOCAL"

Dan juga hal lainnya yang ada di Settingan file excell tersebut (jika perlu), atau nanti saja dulu, karena data diatas dulu saja yang di input duluan. Yang lainnya bisa nanti saja di akhir acara membuat sistem pppoe ini.

Kemudian, ikuti langkah berikut : (ingat, sesuaikan dengan situasi dan kondisi dan keinginan om, saya mencontohkan settingan punya warkop free wifi saya saja)

1. Klik Menu PPP – klik pada Tab PPPoE Servers. Add – dan isi data sebagai berikut :

2. Lalu buat IP Pool untuk si PPPoE kita. Klik menu IP – Pool, dan setting si ip pool untuk pppoe menggunakan ip address local : 10.5.51.2-10.5.51.254

3. Kemudian kita kembali ke Menu PPP – klik pada Tab Profile. Add – dan akurin dengan punya Langsung Viral di bawah ini sebagai contoh.

4. Selanjutnya membuat settingan Profile PPPoE nya, menggunakan perhitungan Excel Script Part 4.5 Om Ega. Lihat gambar berikut ini :

Disini saya akan melimit kecepatan user pppoe menjadi hanya : Upload nya 2M dan Download nya 4M saja om.

5. Masuk lagi ke Menu PPP – lalu Masuk ke Tab Profile, masuk lagi ke tab Script dan isi datanya. Pada bagian On Up, copy paste baris kode berikut ini :

:local address [/ppp active get [/ppp active find name="$user"] address]
:log warning "$user login dengan ip $address"
:log warning "$user login dengan ip $address"
:local datetime [/system clock get date];
:local timedate [/system clock get time];
[/queue simple add max-limit=2M/4M name=("$user") comment="user_pppoe" parent="3.USER HOTSPOT&RUMAHAN" \ target="$address"];

Lalu pada bagian On Down, copy paste baris code berikut ini :

:log error "$user logout"
:log error "$user logout"
/queue simple remove [find name="$user"] ;

Lihat gambar berikut :

Catatan : Default profile itu awalnya pilih default, baru setelah langkah 3 diatas, kita kembali lagi ke tab pppoe server dan berubah default profile dari default menjadi profile pppoe. Begitu om.

6. Selanjutnya Buat User PPPoE. Om masuk ke – PPP – ke tab Secret, yaitu tempat pembuatan User PPPoE

Setting seperti tampilan berikut :

7. Sekarang tinggal test di Laptop kita. Pertama-tama, yakinkan laptop sudah terkoneksi ke Jaringan WiFi Hotspot kita, dalam hal ini adalah ke ether3, ether4 dan ether5 atau disingkat masuk ke bridge1 – terserah masuknya apakah melalui kabel Lan atau secara Wireless WiFi

8. Pilih salah satu WiFi yang tersedia, dimana WiFi tersebut memang disebarkan oleh bridge1 – bisa juga dengan langsung colok kabel LAN ke Laptop, dimana kabel tersebut memang bersumber dari bridge1 (justru itu lebih stabil, jika dengan kabel, daripada dengan WiFi)

Lihat Gambar berikut ini :

9. Buka Network Connection di Laptop om. Pilih Setup New Connection or network

10. Pilih Connect to the Internet

11. Pilih Broadband PPPoE

12 Masukkan Username dan Password yang diberikan oleh Admin.

13. sedang dilakukan koneksi

14. sukses om

15. cek kecepatan koneksi – alhamdulillah sesuai yang diinginkan yaitu 2M/4M, tapi dapatnya di bawah ini ngedrop banget, ya tergantung kondisi isp kita om dan tergantung lain-lain misalnya trafik padat di warkop free wifi nya dll.

16. jika sudah sukses ada tulisan broadband connection

17. dan tidak dapat mengakses login page wifi hotspot

Ketika login page mikrotik diakses, maka yang keluar adalah halaman Mercusuar Telkom

18. dan ini beberapa penampakan hasil akhirnya untuk sistem pppoe yang telah berhasil dibuat, kurang lebih seperti ini :

Demikian, semoga bermanfaat. (LV – PP)

Tags: #Hotspot #Interface #Mikhmon #Mikrotik #PPPoE #Setting #WiFi